在Kali Linux 上安装搜狗输入法 | MrFeng's blog

自从玩上Kali,每次用自带的iBus输入法都感觉浑身难受。。直到前时间(貌似是2014年4月17日)由国内Linux系统团队Ubuntu Kylin与搜狗公司联合开发的搜狗输入法Linux版正式发布。。

(官网 http://pinyin.sogou.com/linux/   )

这尼玛果断要折腾一下啊。。不过仔细一看发布的版本支持:Ubuntu12.04及14.04要求 fcitx 版本大于 4.2.8.3-3

kali是debian7的,fcitx版本没那么高,从官方源里能看到这个版本的fcitx但是apt-get就是装不上,ppa源添加完也不好使(不知道为啥,求指点)。。

那就手动下载安装吧。

进入官方源:

http://http.kali.org/pool/main/f/fcitx/

下载以下文件(这里是64位的,32位找对应项就行了):

fcitx-libs_4.2.8.4-3~bpo70+1_amd64.deb fcitx-libs-qt_4.2.8.4-3~bpo70+1_amd64.deb fcitx-bin_4.2.8.4-3~bpo70+1_amd64.deb fcitx-data_4.2.8.4-3~bpo70+1_all.deb fcitx-modules_4.2.8.4-3~bpo70+1_amd64.deb fcitx-module-dbus_4.2.8.4-3~bpo70+1_amd64.deb fcitx-module-kimpanel_4.2.8.4-3~bpo70+1_amd64.deb fcitx-module-lua_4.2.8.4-3~bpo70+1_amd64.deb fcitx-module-x11_4.2.8.4-3~bpo70+1_amd64.deb fcitx_4.2.8.4-3~bpo70+1_all.deb fcitx-tools_4.2.8.4-3~bpo70+1_amd64.deb fcitx-ui-classic_4.2.8.4-3~bpo70+1_amd64.deb

按照上面的顺序依次 dpkg -i , 一定要按照上面的顺序 !不然会有依赖问题!

接下来安装图形界面的配置工具

apt-get install fcitx-config-gtk2

到搜狗输入法官网下载安装包(链接在上面):

sogou_pinyin_linux_1.0.0.0024_amd64.deb

如果之前装过iBus或其他输入法的,需要先把原来的卸载掉:

apt-get remove ibus

解决一个依赖:

apt-get install libopencc1

开始安装:

dpkg -i sogou_pinyin_linux_1.1.0.0037_amd64.deb

1 条评论

欢迎留言